مهندس حمید کرمی

نحوه تجمیع پهنای باند در میکروتیک

فرض کنید شما در شرکتی فعالیت دارین که از ۳ شرکت اینترنت دارد و کاربران از کندی اینترنت شکایت میکنند. میکروتیک این امکان را فراهم می کند براساس متدهای تجمیع پهنای باند بتوانید این ۳ خط اینترنت را به یک پهنای باند پر سرعت تبدیل کنید.

در اینجا آموزش نحوه تجمیع پهنای باند در میکروتیک را در یکی از شرکت ها با استفاده از متد PCC انجام دادم را برای استفاده قرار می دهم:

۱) مرحله اول : تنظیم آدرس های IP برای میکروتیک

/ip address
add address=192.168.1.1/24 interface=ether1 comment=”ISP1″
add address=192.168.2.1/24 interface=ether2 comment=”ISP2″
add address=192.168.3.1/24 interface=ether2 comment=”ISP3″
add address=192.168.100.1/24 interface=ether3 comment=”LAN Gateway”

۲) مرحله دوم : تنظیم Gateway برای میکروتیک

/ip route
add dst-address=0.0.0.0/0 check-gateway=ping gateway=192.168.1.1,192.168.2.1,192.168.3.1

۳) مرحله سوم : تعریف ترافیک در mangle میکروتیک

/ip firewall mangle
add action=mark-connection chain=input comment=”ISP1″ in-interface=ether1 new-connection-mark=”wan1″
add action=mark-connection chain=input comment=”ISP2″ in-interface=ether2 new-connection-mark=”wan2″
add action=mark-connection chain=input comment=”ISP3″ in-interface=ether3 new-connection-mark=”wan3″

add action=mark-routing chain=prerouting comment=”LAN load balancing 3-0″ dst-address-type=!local in-interface=Local new-routing-mark=”Out ISP1″ passthrough=yes per-connection-classifier=both-addresses-and-ports:3/0
add action=mark-routing chain=prerouting comment=”LAN load balancing 3-1″ dst-address-type=!local in-interface=Local new-routing-mark=”Out ISP2″ passthrough=yes per-connection-classifier=both-addresses-and-ports:3/1
add action=mark-routing chain=prerouting comment=”LAN load balancing 3-2″ dst-address-type=!local in-interface=Local new-routing-mark=”Out ISP2″ passthrough=yes per-connection-classifier=both-addresses-and-ports:3/2

add action=mark-routing chain=output comment=”ISP1″ connection-mark=”ISP1 Input” new-routing-mark=”wan1″
add action=mark-routing chain=output comment=”ISP2″ connection-mark=”ISP2 Input” new-routing-mark=”wan2″
add action=mark-routing chain=output comment=”ISP3″ connection-mark=”ISP3 Input” new-routing-mark=”wan3″

۴) مرحله چهارم : تعریف NAT در میکروتیک

/ip firewall nat
add action=masquerade chain=srcnat comment=”ISP1″ out-interface=ether1
add action=masquerade chain=srcnat comment=”ISP2″ out-interface=ether2
add action=masquerade chain=srcnat comment=”ISP3″ out-interface=ether3

۵) مرحله پنجم : تعریف Routeهای مربوط به mangle

/ip route
add distance=1 gateway=192.168.1.1 routing-mark=”Out ISP1″
add distance=1 gateway=192.168.2.1 routing-mark=”Out ISP2″
add distance=1 gateway=192.168.3.1 routing-mark=”Out ISP3″

از این پس ، ترافیک اینترنت شما از تمامی خطوط اینترنت ارسال خواهد شد. می توانید با استفاده از نرم افزار IDM و دانلود یک فایل این تجمیع پهنای باند را تست کنید.

پس از انجام کارهای فوق شما علاوه بر تجمیع پهنای باند اینترنت از امکان Load Balancing و Fail Over Load Balancing بهره مند خواهید بود. همچنین در صورت ارسال اطلاعات که نیاز به برگشت داره داده های ارسال شده دقیقا از همان خط اینترنت ارسال شده به برخواهد گشت. این موضوع مخصوصا در بعضی از سایت های HTTPS که ممکن است در حالت عادی به مشکل برخورد کند، بدون هیچ مشکل پاسخ را کاربر از طریق همان خط اینترنت دریافت خواهد کرد.

در صورتی که با بعضی از سایت های HTTPS به مشکل برخوردید کافی است این سایت ها را در بخش Address List منوی فایروال با یک اسم خاص اضافه کنید. کانکشن ها یا Packetهای این سایت ها را با استفاده از Mangle مارک دار کنید و یک Route مخصوص برای این پکت ها یا کانکشن ها بنویسد که فقط از یک اینترفیس اینترنت خود خارج شوند.

مشکل حل شد. به همین سادگی

 

 

 

1 دیدگاه

پاسخی بنویسید